[ antp.be > Forum ]

[ FAQFAQ - SearchSearch - MemberlistMemberlist - UsergroupsUsergroups - ]

[ RegisterRegister - ProfileProfile - Log in to check your private messagesLog in to check your private messages - Log inLog in ]


Pocket AMC Reader for Android 2.1 available [29.8.2017]
Goto page Previous  1, 2, 3 ... , 13, 14, 15  Next
 
Post new topic   Reply to topic    www.antp.be Forum Index -> Ant Movie Catalog > Mods
Author Message
sts85
PostPosted: 2017-05-19 08:43:20    Post subject: Reply with quote
View user's profile Send private message Visit poster's website Hi Elman,

I try the Alpha 4 version, it is fine.

My proposals for improvement :

- I find the titles of the fields are too bright before the movie title was bold (but less) not the others.

- When I open a movie the picture on top is partial.

- Now we can zoom the picture but we can't go to the next or previous (like in 1.9.1).

- Add a confirmation window to exit the application because it happens often out unintentionally.

- Could we choose the colors at the top of the display ? (I prefer the blue of the old).

Why the Alpha 4 apk can't be installed whithout uninstall the 1.9.1?

It would be insteressant to have the 2 at the same time (other name + other icon).

Thank you grin kind
elman
PostPosted: 2017-05-19 14:46:58    Post subject: Reply with quote
View user's profile Send private message Hi,

sts85 wrote:
I find the titles of the fields are too bright before the movie title was bold (but less) not the others.


This is bug indeed. Will fix that.

sts85 wrote:
When I open a movie the picture on top is partial.


It is designed to be cut. You know, wanted the app to look fancy and modern smile

sts85 wrote:
Now we can zoom the picture but we can't go to the next or previous (like in 1.9.1).


Just swipe left/right for additional images.

sts85 wrote:
Add a confirmation window to exit the application because it happens often out unintentionally.


This is something I considered some time ago, but Android guidelines recommend not to do that. So I guess I will not implement this one.

sts85 wrote:
Could we choose the colors at the top of the display ? (I prefer the blue of the old).


I will put this to the wish list.

sts85 wrote:
Why the Alpha 4 apk can't be installed whithout uninstall the 1.9.1?


Because it is not signed. But don't worry, from now on all releases will be signed, so you will be able to upgrade from 1.9.1. But you will have to uninstall 2.0 alpha first wink

sts85 wrote:
It would be insteressant to have the 2 at the same time (other name + other icon).


I was never planning on doing this. Version 2.0 is direct successor, so in order to do an upgrade, it needs to have same name. However I might be forced to change the icon because Google is not allowing me to publish the app and icon might be the problem.
Ant316
PostPosted: 2017-05-20 11:52:28    Post subject: Reply with quote
View user's profile Send private message Elman

I have been testing this version for a few days now and it seems to be spot on. I have Been playing about with the code in android studio and came up with a few ideas for themes ect and also I have customised the title and app icon to suit my own personal needs. I like the blue that you use for the default so I have experimented with a few other colours. Please take a look and tell me what you think.















Also as I as we discussed before I tried the "fullscreen_image.xml and change android:scaleType="fitCenter" to android:scaleType="center"

This worked but the images are actually too small, is there anyway I can set a custom size/zoom value for the poster art so i can have it some where on the middle of not to big and not to small?
elman
PostPosted: 2017-05-20 23:04:56    Post subject: Reply with quote
View user's profile Send private message I like the idea of color themes so I have refactored code a bit and now it is ready to have new themes implemented really quickly. Will add some new themes a bit later.

I believe that ImageView doesn't have attribute for zoom. So you can't configure it in XML. However you can use Bitmap in Java code and this will allow you to show zoomed image.

BTW How did you like A Blade in the Dark? wink
Ant316
PostPosted: 2017-05-21 12:16:03    Post subject: Reply with quote
View user's profile Send private message Elman
Quote:
I like the idea of color themes so I have refactored code a bit and now it is ready to have new themes implemented really quickly. Will add some new themes a bit later.

I believe that ImageView doesn't have attribute for zoom. So you can't configure it in XML. However you can use Bitmap in Java code and this will allow you to show zoomed image.

BTW How did you like A Blade in the Dark? wink


When will the new code be ready for download ELman?

Yeah I liked Blade in the dark, wink I am a big fan of 80's Horror/thrillers and would put this as one of the best to be honest.

As a big movie fan and collector I have mostly DVD's as I cant get my head around Blu-ray even though I have a Blu-Ray player.

At some point in the future I might start collecting them but I feel as if they over sharpen the pic to the point where it makes the movie unrealistic and takes away the feel of the original release.
confused Most recently I borrowed The terminator on Blu ray (one of my favourite movies) and watched it and even though it was a great picture I found myself distracted with background things rather than enjoying it so I stuck the DVD in and re-watched it and found that it felt more like A movie.

For collectors or anyone one with a large collection this app is great as it keeps things organised but also helps stop buying the same movie twice when out shopping lol! smile

Once again great job Elman.
smile
elman
PostPosted: 2017-05-22 08:50:14    Post subject: Reply with quote
View user's profile Send private message Hi. Code is already pushed to repository on GitHub. I always push the code when it's ready. So feel free to download / rebase your fork. Do you use Github to rebase? If not, you should consider it as it would make your life really easier smile See https://help.github.com/articles/fork-a-repo/ and https://help.github.com/articles/syncing-a-fork/

I'm horror fan myself, as can be seen from my screenshots and Pocket AMC Reader icon smile Check out list of my favorite horrors http://www.imdb.com/list/ls000726778/

Blurays are fine for movies which has been shot with HD/Bluray in mind. But I do agree that for some older movies, HD transfer is not the best thing to do...
Ant316
PostPosted: 2017-05-22 12:35:59    Post subject: Reply with quote
View user's profile Send private message
Quote:
Hi. Code is already pushed to repository on GitHub. I always push the code when it's ready. So feel free to download / rebase your fork. Do you use Github to rebase? If not, you should consider it as it would make your life really easier smile See https://help.github.com/articles/fork-a-repo/ and https://help.github.com/articles/syncing-a-fork/

I'm horror fan myself, as can be seen from my screenshots and Pocket AMC Reader icon smile Check out list of my favorite horrors http://www.imdb.com/list/ls000726778/

Blurays are fine for movies which has been shot with HD/Bluray in mind. But I do agree that for some older movies, HD transfer is not the best thing to do...


Totally agree Elman there is just something about older movies that makes them good. Good to see another Horror fan about lol! I will be sure to check out your imdb list and also test out the new code.

Im not sure what the "fork a repo" is I just usually download the source code from git hub and customise it in android studio to suit myself but I will have a look into it when i get a chance if it makes life easier then Im up for that lol!

Great work.
elman
PostPosted: 2017-05-31 21:09:34    Post subject: Reply with quote
View user's profile Send private message First beta release (v2.0-beta1) is now available. It means this new version is feature complete. If no critical bugs show up, I should be able to release production version in couple of weeks.

Google Play listing is now reactivated, so when time comes, you will be able to upgrade via Google Play Store.

This build is signed, so you have to uninstall any alpha release you might have. It also means that if you use 1.9.1 version, you can upgrade.

Download as usually from Github
https://github.com/elman22/pocket-amc-reader/releases/tag/v2.0-beta1

EDIT
For some reason signed version doesn't work. I will fix that later. Meanwhile I uploaded debug version.


Last edited by elman on 2017-06-01 00:09:51; edited 1 time in total
Ant316
PostPosted: 2017-05-31 23:11:22    Post subject: Reply with quote
View user's profile Send private message
Quote:
First beta release (v2.0-beta1) is now available. It means this new version is feature complete. If no critical bugs show up, I should be able to release production version in couple of weeks.

Google Play listing is now reactivated, so when time comes, you will be able to upgrade via Google Play Store.

This build is signed, so you have to uninstall any alpha release you might have. It also means that if you use 1.9.1 version, you can upgrade.

Download as usually from Github
https://github.com/elman22/pocket-amc-reader/releases/tag/v2.0-beta1


Good Job Elman. Only Downside is every time I upgrade I have to change very thing to my own customsations via sourc code as I keep 2 different copies on my phone My own collection and a friends collection but I dont mind, smile

Great work my friend.

-------------------------------------------------------------------------
EDIT
------------------------------------------------------------------------

Elman i downloaded the apk from github but when it installs its force closing with "UNFORTUNATLY POCKET AMC READER HAS STOPPED".....

any idea's? I wanna test this out if i can.
elman
PostPosted: 2017-06-01 00:14:57    Post subject: Reply with quote
View user's profile Send private message
Ant316 wrote:
Only Downside is every time I upgrade I have to change very thing to my own customsations via sourc code


You should really learn how to make a fork. It will make very easy to reapply your customization on new versions.

Ant316 wrote:
Elman i downloaded the apk from github but when it installs its force closing with "UNFORTUNATLY POCKET AMC READER HAS STOPPED"


Yes, signed version doesn't work. I uploaded debug version which works. Download that one instead.
Ant316
PostPosted: 2017-06-01 00:22:14    Post subject: Reply with quote
View user's profile Send private message
Quote:
You should really learn how to make a fork. It will make very easy to reapply your customization on new versions.


I know elman, Im still new to workign with android source code ect but Im learning as I go. I will have to look into using a fork.


Quote:
Yes, signed version doesn't work. I uploaded debug version which works. Download that one instead.


Yes I have downloaded & installed that version and it working brillantly. I like the "Fixed Pic" option and also the new landscape view is amazing it gives the app a whole new perspective especially when reading the information on the movies. Great work.

ps

watched a little horror slasher from 1989 called "Intruder" directed by Scott Spiegel and starring Sam Raimi, Ted Raimi and Bruce campell, good wee movie for the year and budget some nice old skool effects as well I recommend that one if you havent seen it, wink
elman
PostPosted: 2017-06-01 10:26:17    Post subject: Reply with quote
View user's profile Send private message
Ant316 wrote:
watched a little horror slasher from 1989 called "Intruder" directed by Scott Spiegel and starring Sam Raimi, Ted Raimi and Bruce campell, good wee movie for the year and budget some nice old skool effects as well I recommend that one if you havent seen it, wink


I've seen it like 3 times. Just make sure you watch unrated director's cut. wink
sts85
PostPosted: 2017-06-04 13:54:34    Post subject: Reply with quote
View user's profile Send private message Visit poster's website Hi Elman,

I try the V 2.0 beta 1 version, it is amazing.

I disinstall definitely the 1.9.1.

Thank you for listening to the users grin kind
Ant316
PostPosted: 2017-06-04 13:58:29    Post subject: Reply with quote
View user's profile Send private message Elman

I am trying to open the source code for the latest "pocket-amc-reader-2.0-beta1.zip" file but keep getting this error:

Error:(5, 0) F:\pocket-amc-reader-resources\keystores\keystore.properties (The system cannot find the path specified)

any ideas, I havenever got this before with previous versions of the source code confused

Ant316
elman
PostPosted: 2017-06-05 13:51:55    Post subject: Reply with quote
View user's profile Send private message
Ant316 wrote:
Error:(5, 0) F:\pocket-amc-reader-resources\keystores\keystore.properties (The system cannot find the path specified)


This is file required for apk signing and contains sensitive information. Therefore it is not part of source code.

Does this problem occur when you are importing or when you are building project? Note that there are 2 build variants. You have to build debug because that one doesn't need key (well, technically it does, but it is generated by your IDE).
Ant316
PostPosted: 2017-06-05 16:41:33    Post subject: Reply with quote
View user's profile Send private message
Quote:
This is file required for apk signing and contains sensitive information. Therefore it is not part of source code.

Does this problem occur when you are importing or when you are building project? Note that there are 2 build variants. You have to build debug because that one doesn't need key (well, technically it does, but it is generated by your IDE).


I thought as much Elamn. It happens when I goto import it. Ithe other source codes You give me imort 100% but this one is firing up this error.

confused
elman
PostPosted: 2017-06-05 18:57:47    Post subject: Reply with quote
View user's profile Send private message I have fixed build script, so please download again from Github.
Ant316
PostPosted: 2017-06-05 23:40:12    Post subject: Reply with quote
View user's profile Send private message
Quote:
PostPosted: 2017-06-05 18:57:47 Post subject:
I have fixed build script, so please download again from Github.


still getting the same error

confused confused
elman
PostPosted: 2017-06-06 10:03:16    Post subject: Reply with quote
View user's profile Send private message Just used different computer to download code from Github and everything works fine. I use Linux at home a now I tried Windows 7.

Make sure you have updated file \AndroidStudioProjects\pocket-amc-reader\PocketAMCReader\build.gradle. This new version should contain
Code:
versionCode 84
Ant316
PostPosted: 2017-06-06 12:29:34    Post subject: Reply with quote
View user's profile Send private message
Quote:
Just used different computer to download code from Github and everything works fine. I use Linux at home a now I tried Windows 7.

Make sure you have updated file \AndroidStudioProjects\pocket-amc-reader\PocketAMCReader\build.gradle. This new version should contain


Still no go but i will try updating my whole android studio and try it again later. I will keep you posted
Thanks Elman
Display posts from previous:   
View previous topic :: View next topic  
Post new topic   Reply to topic    www.antp.be Forum Index -> Ant Movie Catalog > Mods All times are GMT + 1 Hour
Goto page Previous  1, 2, 3 ... , 13, 14, 15  Next
Page 14 of 15

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2006 phpBB Group
Template made by antp