[ antp.be > Forum ]

[ FAQFAQ - SearchSearch - MemberlistMemberlist - UsergroupsUsergroups - ]

[ RegisterRegister - ProfileProfile - Log in to check your private messagesLog in to check your private messages - Log inLog in ]


AMCsearch : recherche multi-critères dans un catalogue
Goto page Previous  1, 2, 3 ... 14, 15, 16, 17  Next
 
Post new topic   Reply to topic    www.antp.be Forum Index -> Ant Movie Catalog > Mods
Author Message
Ermac1515
PostPosted: 2013-11-19 10:07:19    Post subject: Reply with quote
View user's profile Send private message Salut baffab, ça fait quelque temps que j'avais pas mis le nez là dedans moi.
Je remarque que AMC a pas mal évolué et que AMC Search n'est pas compatible avec la dernière version.
Tu pense faire une mise à jour ?
baffab
PostPosted: 2013-11-25 19:25:58    Post subject: Reply with quote
View user's profile Send private message Visit poster's website Salut Ermac1515,
je viens à peine de passer à la 4.1 pour mon catalogue, sachant que je pourrais le sauver au format 3.5 que ça ne changerait pas grand chose (@soulsnake : ne le prends pas mal si je n'utilise pas tes améliorations tongue ).
J'ai vu la modification de format. Dès que j'ai un peu de temps j'y jette un œil en espérant qu'il n'y a pas trop de changement dans les structures. Le fait que quelqu'un est intéressé me motivera un peu plus...

baffab.
soulsnake
PostPosted: 2013-11-25 20:02:04    Post subject: Reply with quote
View user's profile Send private message Send e-mail Salut baffab,

Pas de problème. Les améliorations ne sont pas juste dans le format du catalogue de toute façon wink. Le format 4.1 est simplement utile si tu utilises des champs personnalisés et des étiquettes couleur sur les films. Par contre le format 4.2 qui est déjà disponible en beta et qui va bientôt sortir en version stable apporte de nouveaux champs et la possibilité d'avoir un nombre illimité d'extras pour chaque film pour stocker ce qu'on veut comme des affiches du film, des captures du film, les acteurs principaux du film en photo, des liens vers des bandes annonces ou vidéos ou bonus sur le web ou sur disque, ...

Soulsnake.
chano22000
PostPosted: 2013-11-25 22:41:31    Post subject: Un autre utilisateur d'AMCsearch Reply with quote
View user's profile Send private message Merci pour ce logiciel et de le maintenir en vie !
Ermac1515
PostPosted: 2013-11-27 09:38:14    Post subject: Reply with quote
View user's profile Send private message A mon avis ça va être du boulot, mais c'est précisément les améliorations que j'apprécie :

Champs perso, étiquette couleur, nouveaux champs et extras.
Depuis le temps que je voulais pouvoir mettre d'autres affiches ou les photos d'acteurs.

L'idéal resterait de pouvoir faire des "fiches" acteur, mais il faudra d'abord que ça se fasse dans le logiciel original je pense. Tout comme les champs "nominations" et récompenses". En plus, c'est tout des trucs qui doivent pouvoir s'importer d'Allociné à mon avis.
Si le développeur d'amc passe par là... ^^

Sinon baffab, au cas où tu ai à changer pas mal de chose pour arriver à intégrer les nouveautés, si tu pouvais voir pour améliorer ça au passage :

1 - manque de fluidité pendant les recherches pour les grosses listes (en comparaison à amc) et pour annuler une recherche en revenant à la liste entière.

2 - recherche auto
Quote:

Ah oui, je crois pas te l'avoir déjà demandé. Tu crois qu'il est possible de faire en sorte d'afficher les résultats de recherche au fur et à mesure que l'on tape le mot recherché ? (comme dans AMC en fait)
De telle sorte qu'on ai pas à cliquer sur rechercher pour lancer la recherche.
De la façon dont je m'y prends c'est compliqué.


3 - plus lent qu'amc à ouvrir un gros catalogue

4 - pour l'affichage d'une liste en groupant les films, il faudrait pouvoir faire comme sur amc, c'est à dire que les différents groupes apparaissent "réduits", avec un petit "+"pour agrandir et un petit "-" pour réduire.
Sinon ça affiche une liste de la même taille que sans groupage, ce qui n'est pas forcément pratique.

5 - quand on demande l'affichage de plusieurs champs de recherche vides au démarrage, les champs "Acteurs" et "Catégories" ont la première valeur de la liste renseignée par défaut., Il faudrait qu'ils se charge sans valeur.

Voilà ce qui me vient à l'idée pour le moment.

Sinon, même si je ne t'avais pas fait de requête depuis longtemps, ton logiciel reste celui que j'utilise depuis tout ce temps tu sais.

bon courage !!


Last edited by Ermac1515 on 2013-11-29 13:15:06; edited 1 time in total
baffab
PostPosted: 2013-11-28 23:31:09    Post subject: Reply with quote
View user's profile Send private message Visit poster's website Si j'ai bien compris je vais de voir m'y remettre sérieusement...

Je vais donc regarder les modifications sur le nouveau format et les améliorations et optimisations possibles à partir de la semaine prochaine.
fulvio53s03
PostPosted: 2013-12-26 12:46:32    Post subject: Reply with quote
View user's profile Send private message
baffab wrote:
....les modifications sur le nouveau format et les améliorations et optimisations possibles à partir de la semaine prochaine.


No news? wow wow
Merry XMAs & HAppy New Year!!!!
innocent innocent
baffab
PostPosted: 2013-12-30 16:43:57    Post subject: Reply with quote
View user's profile Send private message Visit poster's website J'ai commencé la gestion du nouveau format. Il me reste quelques bricoles, principalement sur la gestion des nouveaux champs dans l'appli. Je suis par contre passé entre temps à une autre appli donc j'ai un peu mis ça de coté mais j'y retourne donc une version avec le nouveau format sera dispo en fin de semaine.
Pour les optimisations, il va falloir attendre un peu, je dois refaire une partie du code.

Et bonnes fêtes...
fulvio53s03
PostPosted: 2013-12-31 18:09:14    Post subject: Reply with quote
View user's profile Send private message
baffab wrote:
J'ai commencé la gestion... ... il va falloir attendre un peu, je dois refaire une partie du code.

Et bonnes fêtes...

Merci, mon ami...
Encore bonnes fêtes a toi!
up
baffab
PostPosted: 2014-01-07 23:35:17    Post subject: Reply with quote
View user's profile Send private message Visit poster's website Bon ça y est, une nouvelle version qui gère le nouveau format 4.2. Ça a pris plus de temps que prévu, non pas pour la gestion directe du nouveau format mais plus de son intégration dans l'appli. Il reste quelques bricoles plus ou moins importantes mais on va commencer avec cette version en attendant la suite. Vu que j'utilise très peu les nouveaux champs, j'ai fait quelques tests mais je n'ai peut-être pas identifié toutes les possibilités donc il peut rester des cas où il y a des problèmes.

Principales nouveautés de cette 3.6.0 :
    - Gestion du format amc 4.2
    - Mise à jour des modèles spécifiques (templates)
    - Possibilité de définir la couleur d'affichage à partir de l'étiquette couleur
    - Ajout de la version du catalogue dans la fenêtre de propriétés
Ermac1515
PostPosted: 2014-01-08 11:11:17    Post subject: Reply with quote
View user's profile Send private message Salut baffab, merci pour cette nouvelle version.

Par contre, gros problème, là où la version précédente met de 10 à 15 seconde pour m'ouvrir mon cata, cette nouvelle version met de 50 à 60 secondes, ce qui fait quand même un peu plus long.

Au passage, propos d'une des modifications que tu avais faite dan sla version 3.5.2 :
Quote:

Une petite version 3.5.2 avec de légères modifications juste pour le maintenir en vie :

- Affichage de la liste des films dans une infobulle en passant le curseur de la souris sur le lien des acteurs (avec l'utilisation de modèles avec liens des acteurs), limitation de la taille des infobulles qui peuvent n'afficher qu'une partie de la liste



En faisant ça, tu as supprimé la possibilité dans les options de faire comme c'était avant, à savoir l'utilisation de l'infobulle pour le nombre d'occurences plutôt que la liste de films. Tu pense que tu pourrai remettre cette case dan les options ? Bien entendu, si on choisi l'infobulle pour le nombre d'occurence, on renoncera dès lors à l'utiliser pour la liste de films.


CTPLM, @+
baffab
PostPosted: 2014-01-08 12:47:25    Post subject: Reply with quote
View user's profile Send private message Visit poster's website Hello,
Ermac1515 wrote:
Par contre, gros problème, là où la version précédente met de 10 à 15 seconde pour m'ouvrir mon cata, cette nouvelle version met de 50 à 60 secondes, ce qui fait quand même un peu plus long.

Bizarre, surtout avec autant de différence. Je n'ai pas constaté de différence particulière chez moi mais je vais regarder ça. Peut-être un paramètre qui est mal positionné (je ne vois pas trop pourquoi mais on ne sait jamais). Si tu as sauvé les options, copie l'exe ailleurs (sans le fichier de conf xml) ou arrange-toi pour ne pas avoir l'exe et le xml avec le même nom, et lance-le pour voir ce que ça donne avec les valeurs par défaut.

Ermac1515 wrote:
En faisant ça, tu as supprimé la possibilité dans les options de faire comme c'était avant, à savoir l'utilisation de l'infobulle pour le nombre d'occurences plutôt que la liste de films. Tu pense que tu pourrai remettre cette case dan les options ? Bien entendu, si on choisi l'infobulle pour le nombre d'occurence, on renoncera dès lors à l'utiliser pour la liste de films.

Ça devrait pouvoir se faire de choisir ce que l'on désire afficher dans l'infobulle.
Ermac1515
PostPosted: 2014-01-08 13:18:12    Post subject: Reply with quote
View user's profile Send private message J'ai retenté sans aucun autre fichier avec le même nom, c'est pareil. J'ai essayé avec un cata enregistré en version 4.2.0 de amc et un en version antérieure et le problème est le même aussi.

Dès que j'utilise ta version 3.6.0, ça triple le temps de chargement. Je sais pas pourquoi non plus.
baffab
PostPosted: 2014-01-08 14:42:39    Post subject: Reply with quote
View user's profile Send private message Visit poster's website J'ai une idée sur l'augmentation du temps. C'est justement l'évolution que tu mentionnes sur la liste des films qui ralentit considérablement le chargement. Une solution temporaire est de désactiver le préchargement des champs (Options > Recherche/Occurrences > Charger les champs) mais tu perdras également le nombre d'occurrences. Je vais donc faire une modification pour différencier ces 2 options (occurrence et liste de films). Et dans un deuxième temps je vais me pencher sur une optimisation de tout ça.
baffab
PostPosted: 2014-01-14 12:40:03    Post subject: Reply with quote
View user's profile Send private message Visit poster's website bon ça y est, j'ai corrigé ce problème de perfs et d'infobulle avec la 3.6.1 :
    - Choix de l'affichage dans les infobulles : nombre d'occurences ou liste de films
    - Optimisations lors du chargement avec infobulles de la liste des films


On peut choisir d'afficher le nombre d'occurrences ou la liste des films dans les infobulles (ou rien...). Le chargement d'un catalogue est beaucoup plus rapide dans le premier cas mais quand même plus rapide que précédemment dans tous les cas. J'espère que ça ira mieux pour toi Ermac1515.
Ermac1515
PostPosted: 2014-01-16 10:34:13    Post subject: Reply with quote
View user's profile Send private message Merci, il semble bien que tu a corrigé le problème de vitesse. Par contre, autre problème plus embêtant, maintenant quand je sélectionne "non" ou "Nbre de film" pour l'infobulle, après redémarrage du logiciel, l'affiche et la fiche du film ne s'affichent plus.
Par contre tout va bien quand je coche "Liste de film".

Petit détail, quand je sélectionne donc l'une des 2 options qui bug, que je ferme le logiciel (et donc que je sauvegarde comme ça) et que je le ré-ouvre avec une version antérieure comme la 3.5.1.0, le bug reste aussi. C'est sûrement normal mais on sait jamais, ça pourrait t'aider.
baffab
PostPosted: 2014-01-16 11:28:42    Post subject: Reply with quote
View user's profile Send private message Visit poster's website Je viens de faire quelques tests et je n'arrive pas à reproduire ton problème. Je vais continuer à investiguer.
baffab
PostPosted: 2014-02-06 23:28:07    Post subject: Reply with quote
View user's profile Send private message Visit poster's website Petite mise à jour, V3.6.2 :
    - Gestion des infobulles et indices avec l'affichage sans modèle
    - Modifications du modèle de l'export au format image


@Ermac1515: j'ai fais quelques modifs sur la gestion des infobulles, j'espère que ça résoudra tes problèmes.
Ermac1515
PostPosted: 2014-02-07 17:30:58    Post subject: Reply with quote
View user's profile Send private message Alors le problème reste le même, mais je viens de remarquer quelque chose qui devrait peut être t'aider à comprendre.
En fait, le bug dont je te parle n'est actif que quand je ne coche aucune des 2 cases du nombre d'occurences (ni indice, ni modèle).
Mais si je coche par exemple "indice", il n'y a plus de bug. Mais c'est couillon parce qu'au final je me retrouve avec le nombre d'occurence en infobulle ET et indice.
J'espère que ça va te permettre de comprendre un peu mieux.
Merci en tout cas.
baffab
PostPosted: 2014-02-09 18:46:45    Post subject: Reply with quote
View user's profile Send private message Visit poster's website Ça y est j'ai vu reproduire le problème : ça arrive lorsqu'on n'utilise pas de modèle pour l'affichage de la fiche, hors comme j'utilise généralement un modèle pour afficher la fiche je n'ai pas vu ce problème. Il me faudrait penser à systématiquement vérifier ce cas. Maintenant je vais pouvoir faire la correction adéquate.
Display posts from previous:   
View previous topic :: View next topic  
Post new topic   Reply to topic    www.antp.be Forum Index -> Ant Movie Catalog > Mods All times are GMT + 1 Hour
Goto page Previous  1, 2, 3 ... 14, 15, 16, 17  Next
Page 15 of 17

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2006 phpBB Group
Template made by antp